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1. Introduction 

1.1 Background 

The Fault Tree and Damage Assessment List (FTD) utility is designed to assist in the 
development of criticality analyses.  It provides an interactive graphical user interface (GUI) for 
the construction, editing, and viewing of deactivation diagrams (fault trees) and damage 
assessment lists (DAL).  It also provides checking and debugging capabilities to ensure 
completeness and consistency of analyses.  FTD includes full support for the Fault Tree Markup 
Language (FTML) format.1  This document is a functional description of FTD. 

1.2 Basic Elements and GUI 

FTD runs on UNIX, Mac OS X, and Windows 2000 platforms.  Thus, the appearance and 
behavior of the utility vary slightly from platform to platform. (Note that graphics in this 
document were generated on a computer running RedHat Linux 9.)  As shown in figure 1, there 
are two views (distinguished by the tabs labeled “DAL” and “Fault Tree”) in which to work.  
The DAL view displays a table where the loss of function of a vehicle can be specified.  The 
Fault Tree view, which is the focus of this document, is divided into two areas.  On the left, there 
is an editing window in which fault trees are constructed, edited, or viewed.  On the right, there 
is a list of the systems that have been created.  The active system, which is the diagram that 
appears in the editing window, is highlighted in blue.  

 

Figure 1.  Example deactivation diagram. 

                                                 
1 Saucier, R.  Fault Tree Representation and Evaluation;  ARL-TR-2923; U.S. Army Research Laboratory:  Aberdeen 

Proving Ground, MD, 2003. 

Component 

System reference 

Arc 

Disjunction Active system 

Tcl Command Window 



 

 2

The utility’s menu bar, located at the top of the window, offers a number of menus to include 
File, Edit, Tools, Options, Preferences and Help.  These menus are explained in detail in the 
following sections.  In the bottom portion of the GUI, there is a Tool Command Language (Tcl) 
Command Window in which Tcl commands can be evaluated.* 

As shown in figure 1, the basic elements in a system or fault tree are arcs, components, system 
references, and disjunctions.  The definitions for each are as follows: 

• Arc – a vertical connecting line used to connect elements in a series path. 

• Component – a box representing a critical component within a system. 

• System reference – a box representing a system without displaying the fault tree. 

• Disjunction – a set of parallel paths. 

Each of the basic elements has a pop-up menu associated with it.  These menus are described in 
section 2. 

2. Pop-Up Menus 

The basic elements (arc, component, system reference, and disjunction) and the active system 
have commands that can be applied to them and are made available through pop-up menus.  
Each of these menus and the associated commands are explained in the following sections. 

2.1 Arc Menu 

The arc menu, which is activated by right-clicking on an arc, provides commands to perform 
operations on the selected arc (see figure 2).  Descriptions of the commands follow:   

• Paste – inserts the clipboard contents (i.e., copied or deleted objects) into the diagram. 
This command will be nonselectable if no objects have been copied or deleted. 

• New – creates a new object (component, system reference, or disjunction). 

• Properties – outputs internal coding information used by developers. 

                                                 
* For additional information on Tcl, see Ousterhout, J. K.  Tcl and the Tk Toolkit.  Addison-Wesley:  Reading, MA, 1994. 



 

 3

 

Figure 2.  Arc menu. 

2.2 Component Menu 

The component menu, which is activated by right-clicking inside of a component, provides 
commands to perform operations on the selected component (see figure 3).   Descriptions of the 
commands follow: 

• Copy – copies the component to the clipboard. 

• Delete – deletes the component from the diagram and moves it to the clipboard. 

• Rename – assigns a new name to the component. 

• Set fill color – sets the background color of the component. 

• Set outline color – sets the color of the outline for the component. 

• Font style – sets the style of the font for the component name (e.g., bold, italic, underline, 
and overstrike). 

• Properties – outputs internal coding information used by developers. 

 
 

 

 
The clipboard feature in this utility is a temporary data storage area in 
which the most recently copied or deleted object is stored.  It is 
comparative to the clipboard in popular desktop publishing applications.  
However, the Delete command in FTD functions like the Cut command in 
other applications.  It removes an object from the diagram and transfers it 
to the clipboard.  The object can then be pasted elsewhere in a diagram. 
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Figure 3.  Component menu. 

2.3 System Reference Menu 

The system reference menu, which is activated by right-clicking inside of a system reference, 
provides commands to perform operations on the selected system reference (see figure 4).  By 
default, a system reference is a light blue-purple color.  If a system and the corresponding system 
reference (they have the same name) have been created in the same file, the system reference 
will be a dark blue-purple color.  Descriptions of the menu commands follow: 

• Raise – makes the system that corresponds to the selected system reference the active 
system.  This command will be unavailable if the corresponding system has not been 
created in the current file. 

• Copy – copies the system reference to the clipboard. 

• Delete – deletes the system reference from the diagram and moves it to the clipboard. 

• Rename – assigns a new name to the system reference. 

• Set fill color – sets the background color of the system reference. 

• Set outline color – sets the color of the outline for the system reference. 

• Font style – sets the style of the font for the system reference. 

• Properties – outputs internal coding information used by developers. 

• Show DAL – makes the DAL view the active view if there is a corresponding entry in the 
DAL view. 



 

 5

 
Figure 4.  System reference menu. 

2.4 Disjunction Menu 

The disjunction menu, which is activated by right-clicking on either of the horizontal lines 
associated with a disjunction, provides commands to perform operations on the selected 
disjunction (see figure 5).  Descriptions of the commands follow: 

• Add a path – adds a path to the right side of the selected disjunction. 

• Copy – copies the entire disjunction to the clipboard. 

• Delete – deletes the disjunction from the diagram and moves it to the clipboard. 

• Delete a path – deletes the specified path (paths are numbered in ascending order from 
left to right).  The deleted path will not be moved to the clipboard. 

• Properties – outputs internal coding information used by developers. 

 

Figure 5.  Disjunction menu. 
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2.5 Background Menu 

The background menu, which is activated by right-clicking on the white background in the 
editing window, provides commands to perform operations on the active system (see figure 6).  
Descriptions of these commands follow: 

• Clear system – deletes all objects from the active system without moving them to the 
clipboard. 

• Redraw – refreshes the display of the active system. 

 

Figure 6.  Background menu. 

3. Edit Menu 

The primary purpose of the Edit menu is to create systems.  To create a system, the user needs to 
select “Create a system” from the Edit menu (see figure 7) and enter the name of the system.∗   
An arc will be drawn in between a starting and an ending marker.  The user must right-click on 
the arc to activate the arc menu.  The user should then select “New” from this menu and choose 
which type of object to create and enter in the requested information (name or number of paths).  
The object will be drawn at the position where the user right-clicked originally.  The steps used 
to create this object should be repeated until the fault tree is completed. 

                                                 
∗ System, component, and system reference names should not contain parentheses () or square brackets [].  In addition, system 

names should not be exclusively numbers. 
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Figure 7.  Edit menu. 

4. File Menu 

The File menu provides the following commands:  Open, Import, Export, Save, Close, and Exit.  
These commands are explained in detail in the following sections. 

 

Figure 8.  File menu. 
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4.1 Open 

The “Open” command allows the user to open an existing FTD (.ftd) or FTML (.ftml) file.  To 
open a file, the user must select “Open” from the File menu and specify in the dialog box which 
file to open.  To select a file, the user needs to either highlight the file and press OK, or double-
click on the file.  If a file is already opened when the Open command is invoked, a dialog box 
will appear asking the user if the current file should be saved before opening another file. 

4.2 Import 

The “Import” command reads in a list of component names and makes them available to the user 
when constructing fault trees.  The component names should be in a text (.txt) file and separated 
by whitespace (e.g., a space, tab, or carriage return).  To import a list, the user first needs to 
select “Import” from the File menu and then select the file to import.    Once the list is imported, 
the component names will appear in a drop-down combo box accessible to the user when a new 
component is created.  Figure 9 shows the component dialog box with the drop-down combo box 
displayed. 

 

Figure 9.  Component dialog box. 

 
 

 

 
Note that if you are using Microsoft Windows 2000, you must type the 
appropriate file name extensions (for example, .ftd, .pdf, .ftml, .txt) when 
saving and exporting files.  On UNIX and Mac OS X operating systems, 
the appropriate file extension will automatically be appended to file names 
if one is not provided. 
 

4.3 Export 

The “Export” command exports fault trees to Portable Document Format (PDF) and FTML file 
formats.  This command also exports DALs to tab-delimited text files.  To export fault trees or 
DALs, the user needs to select “Export” from the File menu, enter a file name, select a file type, 
and press the Save button (see figure 10).  

• DAL file – To export a DAL to a file, the user needs to enter the desired file name and 
ensure that the selected file type is DAL Files (see figure 10).  The DAL will be written 



 

 9

to a tab-delimited text file that can be imported into desktop publishing applications such 
as Microsoft Excel.  Note that file names should have a .txt extension.   

• PDF file – To export a fault tree to a PDF file, the user needs to enter the desired file 
name and ensure that the selected file type is Portable Document Format Files (see figure 
10).  Only the active system will be written to the file.  The PDF can be viewed using 
Adobe Acrobat Reader.  It can also be inserted into a Microsoft Word document or 
PowerPoint presentation.  Note that file names need to be saved with a .pdf extension.   

• FTML file – To export an FTML file, the user needs to enter the desired file name and 
ensure that the selected file type is Fault Tree Markup Language Files (see figure 10).  
Only the active system will be written to the FTML file.  Attribute information such as 
fill color and font style will not be stored.  When an FTML file is opened in FTD, the 
default colors and font style will be displayed.  Note that file names need to be saved with 
an .ftml extension. 

 

Figure 10.  Export dialog box. 

4.4 Save 

The “Save” command stores all of the systems created in an FTD file.  All of the fault trees – 
including attribute information such as component and system reference names, fill color, and 
font style – and DALs are stored in this file.  The software does not automatically save files, so 
the user should save his/her work periodically.  To save a file, the user needs to select “Save” 
from the File menu and enter a file name.  Note that file names need to be saved with an .ftd 
extension.   
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4.5 Close 

The “Close” command will close the current file without saving any changes.  Only the current 
file will be closed.  The program will not be terminated.  To close a file, the user must select 
“Close” from the File menu.   

4.6 Exit 

The “Exit” command will terminate the program without saving any changes to the current file.  
To quit FTD, the user needs to select “Exit” from the File menu. 

5. Tools Menu 

The Tools menu provides the following commands: Go to, Search, Sanity Check, Sysdef, and 
Sort.  These commands are explained in detail in the following sections.  

5.1 Go To 

The “Go to” command displays a hierarchical view of the current file and allows the user to 
jump directly to a selected system.  To activate this feature, the user must select “Go to” from the 
Tools menu (shown in figure 11).  Initially, a list of all of the systems will be displayed in 
alphabetical order (see figure 12).  To view a complete list of components and system references 
within a system, the user needs to single-click on the closed folder icon (see figure 13).  To make 
a system the active system from this view, the user must double-click on a system, component, 
or system reference name. 

 

Figure 11.  Tools menu. 
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  Figure 12.  Initial “Go to” list.  Figure 13.  “Go to” list with a system 
expanded. 

5.2 Search 

The “Search” command allows the user to search for a specific component or system reference 
by name.  To begin a search, the user must select “Search” from the Tools menu and enter the 
name or pattern for which to search.  This search is case insensitive and uses glob-style matching 
rules (*, ?, [], and \).  If only one match is found, or if there are multiple finds in the same 
system, the system containing the item(s) will become the active system.  If the item is found in 
more than one system, a list will be displayed.  The user needs to double-click on a system name 
in the list to make it the active system or single-click on the system name and press OK. 

5.3 Sanity Check 

The “Sanity Check” command performs checks to see if there are any system references that do 
not have corresponding systems defined in the current file and if any systems do not have 
corresponding entries in the DAL.  To activate this feature, the user must select “Sanity Check” 
from the Tools menu.  After the check is finished, the results will be displayed. 

5.4 Sysdef 

The “Sysdef” command outputs MUVES system definition code for all of the systems to a text 
file.  To create the system definition file, the user must select “Sysdef” from the Tools menu and 
enter the desired file name.  File names should have a .txt extension. 

5.5 Sort 

The “Sort” command displays the current list of systems in ascending order.  Any systems 
created after the sort operation has been performed will be displayed in the order in which they 
were created, not necessarily in alphabetical order.  To sort the systems list, the user must select 
“Sort” from the Tools menu.   
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6. Options Menu 

The Options menu provides viewing options for the utility.  These options are explained in detail 
in the following sections. 

6.1 Tcl Command Window 

The Tcl command window provides a pane in which Tcl commands can be evaluated.  As shown 
in figure 14, there is a button to enable or disable the Tcl command window.  When this button is 
selected, the Tcl command window will be displayed in the bottom portion of the FTD window.  
If the box is deselected, the Tcl command window will not be displayed (see figure 15).   

 

Figure 14.  Options menu. 

 

Figure 15.  Tcl command window disabled. 
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6.2 Diagnostics 

The “Diagnostics” option prints out run-time diagnostics used by the developers for debugging 
purposes.  To perform diagnostics, the user must select “Diagnostics” from the Options menu 
and enable the “Reading input files” button from the cascading menu.  When a file is opened, 
run-time messages will be displayed in the console from which FTD was executed.   

7. Preferences Menu 

At this time, the only preference that can be set relates to the DAL view.  This option is beyond 
the scope of this document.



 
 
NO. OF NO. OF  
COPIES ORGANIZATION COPIES ORGANIZATION 
 

 14

 1 DEFENSE TECHNICAL 
 (PDF INFORMATION CTR 
 ONLY) DTIC OCA 
  8725 JOHN J KINGMAN RD 
  STE 0944 
  FORT BELVOIR VA 22060-6218 
 
 1 US ARMY RSRCH DEV & 
  ENGRG CMD 
  SYSTEMS OF SYSTEMS 
  INTEGRATION 
  AMSRD SS T 
  6000 6TH ST STE 100 
  FORT BELVOIR VA  22060-5608 
 
 1 INST FOR ADVNCD TCHNLGY 
  THE UNIV OF TEXAS  
  AT AUSTIN 
  3925 W BRAKER LN STE 400 
  AUSTIN TX 78759-5316 
 
 1 US MILITARY ACADEMY 
  MATH SCI CTR EXCELLENCE 
  MADN MATH 
  THAYER HALL 
  WEST POINT NY 10996-1786 
 
 1 DIRECTOR 
  US ARMY RESEARCH LAB 
  IMNE AD IM DR 
  2800 POWDER MILL RD 
  ADELPHI MD 20783-1197 
 
 3 DIRECTOR 
  US ARMY RESEARCH LAB 
  AMSRD ARL CI OK TL 
  2800 POWDER MILL RD 
  ADELPHI MD 20783-1197 
 
 3 DIRECTOR 
  US ARMY RESEARCH LAB 
  AMSRD ARL CS IS T 
  2800 POWDER MILL RD 
  ADELPHI MD 20783-1197 

ABERDEEN PROVING GROUND 
 
 1 DIR USARL 
  AMSRD ARL CI OK TP (BLDG 4600) 
 
 
 
 
 
 



 
 
NO. OF NO. OF  
COPIES ORGANIZATION COPIES ORGANIZATION 
 

 15

 1 OASD C3I 
  J BUCHHEISTER 
  RM 3D174 
  6000 DEFENSE PENTAGON 
  WASHINGTON DC 20301-6000 
 
 1 OUSD(AT)/S&T AIR WARFARE 
  R MUTZELBURG 
  RM 3E139 
  3090 DEFENSE PENTAGON 
  WASHINGTON DC 20301-3090 
 
 1 OUSD(AT)/S&T LAND WARFARE 
  A VIILU 
  RM 3B1060 
  3090 DEFENSE PENTAGON 
  WASHINGTON DC 20310-3090 
 
 1 UNDER SECY OF THE ARMY 
  DUSA OR 
  RM 2E660 
  102 ARMY PENTAGON 
  WASHINGTON DC 20310-0102 
 
 1 ASST SECY ARMY 
  ACQSTN LOGISTICS & TECH 
  SAAL ZP RM 2E661 
  103 ARMY PENTAGON 
  WASHINGTON DC 20310-0103 
 
 1 ASST SECY ARMY 
  ACQSTN LOGISTICS & TECH 
  SAAL ZS RM 3E448 
  103 ARMY PENTAGON 
  WASHINGTON DC 20310-0103 
 
 1 DIRECTOR FORCE DEV  
  DAPR FDZ 
  RM 3A522 
  460 ARMY PENTAGON 
  WASHINGTON DC 20310-0460 
 
 1 US ARMY TRADOC ANL CTR 
  ATRC W 
  A KEINTZ 
  WSMR NM 88002-5502 
 
 1 USARL 
  AMSRD ARL SL EA 
  R FLORES 
  WSMR NM 88002-5513 
 

 1 USARL 
  AMSRD ARL SL EI 
  J NOWAK 
  FORT MONMOUTH NJ 07703-5601 
 
 

ABERDEEN PROVING GROUND 
 
 1 US ARMY DEV TEST COM 
  CSTE DTC TT T 
  APG MD 21005-5055 
 
 1 US ARMY EVALUATION CTR 
  CSTE AEC SVE 
  R BOWEN 
  4120 SUSQUEHANNA AVE 
  APG MD 21005-3013 
 
 1 US ARMY EVALUATION CTR 
  CSTE AEC SVE S 
  R POLIMADEI 
  4120 SUSQUEHANNA AVE 
  APG MD 21005-3013 
 
 1 US ARMY EVALUATION CTR 
  CSTE AEC SV L 
  R LAUGHMAN 
  4120 SUSQUEHANNA AVE 
  APG MD 21005-3013 
 
 14 DIR USARL 
  AMSRD ARL SL 
   J BEILFUSS 
   P DEITZ 
  AMSRD ARL SL B 
   J FRANZ 
   M PERRY 
   P TANENBAUM 
  AMSRD ARL SL BB 
   D BELY 
   D FARENWALD 
   S JUARASCIO 
   M RITONDO 
  AMSRD ARL SL BD 
   R GROTE 
  AMSRD ARL SL BE 
   L ROACH 
  AMSRD ARL SL E 
   M STARKS 
  AMSRD ARL SL EC 
   J FEENEY 
   E PANUSKA 
   



 
 
NO. OF   
COPIES ORGANIZATION  
 

 16

 2 DIR USARL 
  AMSRD ARL D 
   J MILLER 
   D SMITH 
  2800 POWDER MILL RD 
  ADELPHI MD 20783-1197 
 
 25 DIR USARL 
  AMSRD ARL SL E 
  WSMR NM 88002-5513 

 
 

 


